1.6. Python

A number of scripts used for development are written in Python, and require that Python 2.6 or Python 2.7 (but not Python 3.0+) be installed, and able to be invoked from the command line via the python command.

  • On Linux, a suitable version of Python is already installed with most recent distributions.
    Distributions that do not include a suitable version include Red Hat Enterprise Linux 5, and CentOS 5. On these distributions, you will need to download and install a more recent version of Python. Source tarballs are available from the Python website. Alternatively, a suitable RPM may be available.
  • On Windows, you will need to download and install Python.
    Windows installers are available from the Python website.

1.6.1. Additional Python packages required