1.2. Eclipse IDE (Eclipse 4.5.2 “Mars SR2”) - pre-configured version

This section describes how to use a previously-configured Eclipse IDE. See Installing and configuring if you want to do install and configure from scratch.

Instructions are provided for Eclipse 4.5.2 (“Mars SR2”).

1.2.1. For general developers

If you use Windows, or if are not on the Diamond Light Source (DLS) network, we suggest you download and install a pre-configured Eclipse.

  1. Download the most recent Eclipse from alfred.diamond.ac.uk.

  2. untar/unzip as appropriate for your platform.

  3. If you need to specify a network proxy, the best way on Linux is to set environment variables $http_proxy/$https_proxy/$no_proxy before starting Eclipse.
    Alternatively, or if you are on Windows, specify the network proxy within Eclipse, at Window ‣ Preferences ‣ General ‣ Network Connections
  4. At Window ‣ Preferences ‣ General ‣ Startup and Shutdown, disable any plugins you do not require.
  5. Run Help ‣ Check for Updates and restart if necessary

1.2.2. For Diamond Light Source developers (Linux)

At DLS, a shared Eclipse install is available via the module load system. You can use this as follows:

module load java/<version>          # examples: module load java/gdamaster; module load java/gda95
module load eclipse/<version>       # example: module load eclipse/442
eclipse &

Note that module load eclipse script looks to see whether you have a local copy of the requested eclipse version on /scratch. If it finds one, it will use that, otherwise it will use the shared install in /dls_sw/apps/<etc>.

To find out how to install a local copy of Eclipse, simply issue module load eclipse/<version>.

For further information, and a list of what versions are available, see Confluence.